WordPressを4.7にしたら、いきなり不具合が…

稼ぎは月80万円ぐらいですが、アフィリ仲間がいなくて寂しい思いをしています。


先日、WordPressを4.7にバージョンアップしたら、
いきなり不具合が出てしまいました。

その不具合とは、WordPressの管理画面とブログの最上部に、
エラー表示が4行も出たのです。

管理画面だけなら、まだいいのですが、
ブログにも4行のエラー表示が出た状態ですから、
そのまま放置しておく訳にはいきません。

ブログの最上部に、
意味不明な英語がズラ~っと4行もあるのですから、
ブログを訪問してくれた人は、
よからぬブログではないかと思ったかも知れないですね(^^;

という訳で…

スグに修正に取りかかりました。

すると、解決方法はメチャクチャ簡単でした。

その解決方法は、下記の通りです。

①管理画面で「プラグイン」をクリックする。
②「Head Cleaner」の「編集」をクリックする。
②出てきたソースの中から「foreach ($filters as $filter) {」を探し出す。
③その部分に「(array)」を挿入する。

●修正前:foreach ($filters as $filter) {
●修正後:foreach ((array)$filters as $filter) {

④「ファイルを更新」をクリックする。
⑤「Head Cleaner」の「停止」をクリックする。
⑥「Head Cleaner」の「有効化」をクリックする。

要は、「Head Cleaner」が悪さをしていたという訳です(^^;

でも…

文章にすると長いですけど、
実際にやってみると、
1分も掛からずに終わりました。

WordPressって便利なツールですけど、
プラグインの不具合とか結構多いですから、
そういうのが出たときは厄介ですよね。

解決方法がスグ見つかればいいのですが、
苦戦することも少なくないです(^^;

でも…

そういうことを繰り返して、
少しずつ詳しくなっていくしかないですよね。

SIRUSなんかだと、
プラグインとかがないので、
そういう不具合は出たことがないですけど、
ページ数の多いブログを作るなら、
やっぱりWordPressの方がいいですから、
不具合と付き合っていくものだと思って
使っていくものなんでしょうね。

===================================
私のメールアドレスは下記の通りです。
何かあれば、気軽にメールして下さいね。

suzuki8080ewah_0121★yahoo.co.jp
(★を@に変えて送信して下さい)
===================================

にほんブログ村 小遣いブログ アフィリエイトへ
   ↑↑↑↑    ↑↑↑↑    ↑↑↑↑
これを押しておいて頂けると、
私のランキングポイントが一つ増えますので、
宜しくお願い致します。












この記事へのコメント
トミーさんこんにちは!

あなたのおともアフィリエイターゆーろと申します

WordPress4.7そんな不具合あるんですね

知りませんでした

WordPressのバージョンアップは少し様子を見てからした方がいいということですかね

では応援していきます~
コメント&応援ありがとうございます。

WordPress4.7の不具合ではなくて、
プラグインの不具合ですョ。
2017/01/01(日) 09:55 | URL | トミー #-[ 編集]
トミーさん

はじめまして、山本といいます。

僕はトミーさんより年上の50代です。

WordPressはプラグインが怖いですよね~

4.7にバージョンアップする時に、結構ドキドキしました。

できればプラグイン入れたくないけど、そうもいかず。
2017/01/03(火) 00:02 | URL | 山本 #-[ 編集]
コメントありがとうございます。

プラグインも怖いですけど、
テーマのカスタマイズも怖いですよね。

でも、色々と変えたくなるので、
毎回、私もドキドキしながらやってます(^^;
2017/01/03(火) 01:39 | URL | トミー #-[ 編集]
サイトURL
コメント
Pass:
非表示 ⇒ 【管理人だけに見せたい場合】
 

 | Copyright © 50代のアフィリ仲間が欲しくて立ち上げたブログ All rights reserved. | 

アフィリエイト